Falscher Update-Hinweis in Piwik 0.6.2

Wer die Open-Source (GPL lizenzierte) Webanalyse-Software Piwik einsetzt, wird bestimmt bemerkt haben, dass nach dem Update auf die aktuelle Version 0.6.2 oben rechts in der Ecke der Hinweis auf die Piwik Version 1 angezeigt und zum Update aufgefordert wird. Diese Meldung entsteht durch eine fehlerhafte Datei im aktuellen Piwik-Download-Paket.

Es handelt sich um die Datei Http.php, die sich im Ordner /trunk/core/ der Piwik Installation befindet. Die falsche Einblendung könnte man jetzt einfach ignorieren, sonst funktioniert ja alles; allerdings ist der automatische Hinweis  auf eine neue Version so auch lahmgelegt.

Die Reparatur ist ganz einfach: Die fehlerbereinigte Datei Http.php hier (Link entfernt weil veraltet) herunterladen (Piwik-Website). Die Datei per FTP-Programm, ich empfehle WinSCP oder WS_FTP in den entsprechenden Ordner laden und die vorhandene Datei überschreiben, fertig.

Die Änderung ist nicht sofort sichtbar. Jetzt heißt es noch ca. 8 Stunden zu warten, so groß ist das Intervall, in dem Piwik nach einer aktuelleren Version sucht, danach ist wieder die aktuelle Versionsnummer zu sehen.

Menü schließen
Panel schließen